× Bug reports

Debuffs

2 months 3 days ago
TheFreeman
New Member
New Member
Posts: 1
More
Debuffs #1873
Hi, sorry for jumping in. But I seem to have the same problem, every time I am in a dungeon(as a priest) I do not see the Debuffs my party members have. Is this normally set by default or do I need to enable something?

Thanks,
TheFreeman

Please Log in or Create an account to join the conversation.

2 months 3 days ago 2 months 1 day ago by laxing.
laxing
New Member
New Member
Posts: 2
More
Debuffs #1875
No you're not alone I'm having the same issue.

EDIT: 1.13.2.2 Beta 3 magic debuffs still not showing.

Please Log in or Create an account to join the conversation.

1 month 4 weeks ago
jeany
New Member
New Member
Posts: 1
More
Debuffs #1906
I'm having the same issue as a priest too on classic.

I'm using version 1.13.2.2 and I can't see magic debuffs. Diseases work fine though.

Please Log in or Create an account to join the conversation.

1 month 4 weeks ago 1 month 4 weeks ago by Porr3.
Porr3
New Member
New Member
Posts: 1
More
Debuffs #1909
I guess everyone who has problems with magic debuffs not being displayed for priests probably is above level 36, and has therefore learned Dispel Magic Rank 2.
For some reason, Healbot uses the ID of Rank 2 instead of Rank 1 when checking if a spell to remove magic is present.
To "fix" the problem, you need to change the skill ID of Dispel Magic inside the Healbot code, open
Interface\AddOns\HealBot\Locale\HealBot_Global.lua
and search for "HBC_DISPELL_MAGIC", its current value should be 527 (Dispel Magic Rank 1) change that value to 988 (Dispel Magic Rank 2).
There definitely exists a better way to fix this, most likely during the skill identification, but this fix is doable for everyone and should work properly until a real fix is published.
PS: For some reason, the debuff tracking sometimes does not work, this can be fixed by a simple interface reload.
The following user(s) said Thank You HMMMkk, mr3z

Please Log in or Create an account to join the conversation.

1 month 3 weeks ago
HMMMkk
New Member
New Member
Posts: 3
More
Debuffs #1925
The post by Porr3 solved my issue. Thank you so much!

Please Log in or Create an account to join the conversation.

1 month 3 weeks ago
drewb4
New Member
New Member
Posts: 1
More
Debuffs #1935
Monitoring for Debuffs is not working correctly. It doesn't seem to recognize which spells I have that can remove debuffs.

For example:

I am a priest, and I have dispel magic. It lets me select dispel magic on the debuffs > general tab, but when effected by a magic effect my bars never highlight blue or give any notification.

It does however work when I go to Debuffs > Custom and I enable "all magic" However, it displays it in the purple automatic debuffs color, So I can't distinguish the type of debuff.

If I am hit by a debuff and i quickly enable all magic automatic debuffs, and then take it off. The blue magic highlighting will show up briefly until I go out of combat and get hit by another debuff.

Since the automatic debuffs are working but not the debuffs>general, I'm guessing it has something to do with it not recognizing what I am able to dispel?

Tested with multiple different types of debuffs.
HealBot 1.13.2.2

Attachments:

Please Log in or Create an account to join the conversation.

Moderators: ctshammyAcirac