×
Guides and Beta

Get help on options and using healbot
Click here for the guides

Shadowlands Release Candidate
Click here for 9.0.1.0.rc5

× Bug reports

Addon error with new version

1 month 1 day ago
notta's Avatar
notta
Junior Member
Junior Member
Posts: 7
More
Topic Author
Addon error with new version #1
FYI. Error message on login after updating to 1.13.5.2.

Date: 2020-08-29 08:49:48
ID: 1
Error occured in: Global
Count: 18
Message: ..\AddOns\HealBot_Options\HealBot_Options.lua line 1568:
attempt to index field '?' (a nil value)
Debug:
[C]: ?
HealBot_Options\HealBot_Options.lua:1568: HealBot_Options_SetText()
[string "*:OnLoad"]:1:
[string "*:OnLoad"]:1

Please Log in or Create an account to join the conversation.

1 month 1 day ago
Strife's Avatar
Strife
Administrator
Administrator
Posts: 1110
Karma: 8
More
Addon error with new version #2
Did this only occur once or everytime after reload?
It is continues I need the full error stack to see what called the function.

Please Log in or Create an account to join the conversation.

1 month 1 day ago
notta's Avatar
notta
Junior Member
Junior Member
Posts: 7
More
Topic Author
Addon error with new version #3
OK this is really not an issue but here is what I'm seeing. After upgrading I received the error. I play 5 accounts. I went in enabled Healbot on 3 accounts and now after loading or login the message goes away. The other 2 accounts where Healbot is not loaded I am receiving the error messages every time I login or console reload. I then went in a looked at my addons and some components of Healbot were enabled on the 2 accounts getting the error. I went in and unchecked the other sub components and now the error is gone on the other 2 accounts.

Here is what I had checked for the other 2 accounts that was enabling the error message. Healbot is not needed on these 2 accounts.

Please Log in or Create an account to join the conversation.

1 month 1 day ago
Strife's Avatar
Strife
Administrator
Administrator
Posts: 1110
Karma: 8
More
Addon error with new version #4
I am not able to replicate that but it you turn off HealBot Data on those accounts, the error should go away.

Please Log in or Create an account to join the conversation.

3 weeks 6 days ago 3 weeks 6 days ago by Kayeraye. Reason: unchecked healbot data
Kayeraye's Avatar
Kayeraye
Visitor
Visitor
Addon error with new version #5
I am also not able to get classic version to load. It's giving me errors but I'm not sure how to find those errors. I have unchecked Healbot Data and it does not help.
Attachments:

Please Log in or Create an account to join the conversation.

3 weeks 5 days ago
Strife's Avatar
Strife
Administrator
Administrator
Posts: 1110
Karma: 8
More
Addon error with new version #6
You need Healbot Data turned on to use healbot, try hitting the defaults button and then reload the ui

Please Log in or Create an account to join the conversation.

Moderators: ctshammyAcirac