×
Guides and Beta

Get help on options and using healbot
Click here for the guides

HealBot Beta's
None currently available

× Bug reports

LUA Error with newest version

2 weeks 1 day ago
Polyhymnea's Avatar
Polyhymnea
New Member
New Member
Posts: 2
More
Topic Author
LUA Error with newest version #1
This may sound weird but all this started when I was unable to target players with my Standart Shift+left. It was always on Target (i play with the german localization so this shouldnt happen.). After this i tried to do the steps as it was advised (cleared it etc.) but now i only get an LUA error and am not be able to load it.
lua error below:
Message: Interface\AddOns\HealBot\HealBot_Action.lua:3047: attempt to index field 'Anchors' (a nil value)
Time: Tue Oct 6 09:02:19 2020
Count: 1
Stack: Interface\AddOns\HealBot\HealBot_Action.lua:3047: attempt to index field 'Anchors' (a nil value)
[string "@Interface\AddOns\HealBot\HealBot.lua"]:5688: in function `HealBot_OnEvent'
[string "*:OnEvent"]:1: in function <[string "*:OnEvent"]:1>

Locals: self = HealBot {
0 = <userdata>
}
event = "VARIABLES_LOADED"
arg1 = nil
arg2 = nil
arg3 = nil
arg4 = nil
eButton = false
ePrivate = false
HealBot_luVars = <table> {
SoftResetAfterCombat = false
FluidBarAlphaInUse = false
AUXOMAX = 0.950000
MessageReloadUI = 0
PrevTipTime = 239288.310000
healthFactor = 1
fastSwitch = 0
reCheckActionFrames = false
FlashAuxInUse = false
auxAlpha = 0.100000
aRefresh = false
27YardsOnly = false
overhealCastID = "-nil-"
pluginTimeToDie = false
minAggroHealth = 1
PetType = 2
UnitSlowUpdateFreq = 1
IsSolo = true
AuraEventRegistered = false
IconFadeInUse = false
slowSwitch = 0
FluidFlashInUse = false
TargetNeedReset = true
TankUnit = "x"
FluidAuxAlphaInUse = false
VehicleType = 1
DelayLockdownCheck = 239288.310000
FluidAuxInUse = false
RaidTargetUpdate = false
OFREQ = 0.070000
pluginEfficientHealers = false
MaskAuraDCheck = 239288.310000
overhealUnit = "-nil-"
MaskAuraReCheck = false
pluginEffectiveTanks = false
MaxCount = 0
EnableErrorText = false
Timer8000 = 0
overhealAmount = 0
pluginThreat = false
EnableErrorSpeech = false
ChatNOTIFY = 0
showReloadMsg = true
cpLoadTime = 239291.310000
FLUIDSTATEFREQ = 0.050000
AddonMsgType = 3
FLUIDFREQ = 40
ChatMSG = ""
FluidBarInUse = false
TestBarsOn = false
FPS = <table> {
}
fastUpdateEveryFrame = 9
NoSpamOOM = 0
TipUpdateFreq = 1
AUXOMIN = 0.100000
FocusNeedReset = true
qaFRNext = 239333.310000
VersionRequest = false
ReloadUI = 0
TargetUnitID = "player"
ResetFlag = false
}

Page 2:
Message: Interface\AddOns\HealBot\HealBot_Action.lua:3047: attempt to index field 'Anchors' (a nil value)
Time: Tue Oct 6 09:02:19 2020
Count: 1
Stack: Interface\AddOns\HealBot\HealBot_Action.lua:3047: attempt to index field 'Anchors' (a nil value)
[string "@Interface\AddOns\HealBot\HealBot.lua"]:5688: in function `HealBot_OnEvent'
[string "*:OnEvent"]:1: in function <[string "*:OnEvent"]:1>

Locals: self = HealBot {
0 = <userdata>
}
event = "VARIABLES_LOADED"
arg1 = nil
arg2 = nil
arg3 = nil
arg4 = nil
eButton = false
ePrivate = false
HealBot_luVars = <table> {
SoftResetAfterCombat = false
FluidBarAlphaInUse = false
AUXOMAX = 0.950000
MessageReloadUI = 0
PrevTipTime = 239288.310000
healthFactor = 1
fastSwitch = 0
reCheckActionFrames = false
FlashAuxInUse = false
auxAlpha = 0.100000
aRefresh = false
27YardsOnly = false
overhealCastID = "-nil-"
pluginTimeToDie = false
minAggroHealth = 1
PetType = 2
UnitSlowUpdateFreq = 1
IsSolo = true
AuraEventRegistered = false
IconFadeInUse = false
slowSwitch = 0
FluidFlashInUse = false
TargetNeedReset = true
TankUnit = "x"
FluidAuxAlphaInUse = false
VehicleType = 1
DelayLockdownCheck = 239288.310000
FluidAuxInUse = false
RaidTargetUpdate = false
OFREQ = 0.070000
pluginEfficientHealers = false
MaskAuraDCheck = 239288.310000
overhealUnit = "-nil-"
MaskAuraReCheck = false
pluginEffectiveTanks = false
MaxCount = 0
EnableErrorText = false
Timer8000 = 0
overhealAmount = 0
pluginThreat = false
EnableErrorSpeech = false
ChatNOTIFY = 0
showReloadMsg = true
cpLoadTime = 239291.310000
FLUIDSTATEFREQ = 0.050000
AddonMsgType = 3
FLUIDFREQ = 40
ChatMSG = ""
FluidBarInUse = false
TestBarsOn = false
FPS = <table> {
}
fastUpdateEveryFrame = 9
NoSpamOOM = 0
TipUpdateFreq = 1
AUXOMIN = 0.100000
FocusNeedReset = true
qaFRNext = 239333.310000
VersionRequest = false
ReloadUI = 0
TargetUnitID = "player"
ResetFlag = false
}

Please Log in or Create an account to join the conversation.

2 weeks 14 hours ago
Strife's Avatar
Strife
Administrator
Administrator
Posts: 1185
Karma: 8
More
LUA Error with newest version #2
try run
/hb cs
/reload
See if it fixes the issue

Please Log in or Create an account to join the conversation.

2 weeks 13 hours ago 2 weeks 10 hours ago by anneangersbach. Reason: Misleading
anneangersbach's Avatar
anneangersbach
Junior Member
Junior Member
Posts: 9
More
LUA Error with newest version #3
I will leave my original answer, but turns out it's NOT really working after all....

I had that same error after I played around with nvidia surround. I have tried removing all my addons, etc. Still healbot was throwing a big pile of ugly (and recursive) errors...
Right now I'm running wow with nothing but healbot on the newest version successfully.
Here's what I did (so far):
  1. inside my wow folder, rename Cache, Interface and WTF to "...Old" so you can reverse engineer.
  2. start wow (it will create those folders again, clean)
  3. install healbot 1.13.5.1_ALL
  4. start wow
  5. check everything is working
  6. exit wow
  7. delete the healbot files
  8. I go up one version and repeated steps 3-7
  9. now I'm on version 1.15.5.5 and it's peachy
I'll have to see if that still works once I start adding my other add-ons back in - and I would like to try to install 5.5 directly, however I'm a bit annoyed now and will stop for now.
But maybe this'll help someone else stuck with this update.

Please Log in or Create an account to join the conversation.

1 week 4 days ago
Polyhymnea's Avatar
Polyhymnea
New Member
New Member
Posts: 2
More
Topic Author
LUA Error with newest version #4
After a complete re-install and update it works again. :)

Please Log in or Create an account to join the conversation.

Moderators: ctshammyAcirac