× Bug reports for the Retail version of Healbot

Debuff Problems

3 weeks 4 days ago
Maydanoz
Junior Member
Junior Member
Posts: 6
More
Topic Author
Debuff Problems #2226
Hello,

I am having two issues that have popped up recently. I had not changed my Healbot settings.

1) Disabling or even deleting a certain custom debuff no longer stops it from showing. Unchecking Bar Color works, but the debuff icon always shows up. I also tried unchecking All Boss, to no avail. (Example debuff: "Bioluminescence" on Blackwater Behemoth.)

2) Focus frame no longer shows custom debuffs, or at least just "Tainted" on Avatar of Sethraliss. All of my Focus frame settings are the same as the main raid frame.

Have there been any recent changes that may have caused these issues? Any help would be appreciated.

Please Log in or Create an account to join the conversation.

3 weeks 4 days ago 3 weeks 4 days ago by Strife.
Strife
Administrator
Administrator
Posts: 706
Karma: 8
More
Debuff Problems #2227
Regarding the custom debuff issue:
The latest release caches aura events, specifically only the buffs and debuffs that are of interest. When a custom debuff is deleted it should be removed from the cache, but there is a bug resulting in the debuff remaining in the cache.
For now reload the UI to clear the cache, it is fixed in the next version.

Not sure about the focus issue, will need to take a look at that later.

Please Log in or Create an account to join the conversation.

3 weeks 3 days ago
Strife
Administrator
Administrator
Posts: 706
Karma: 8
More
Debuff Problems #2228
Focus issue seems to also be related to the aura cache, saw similar issues with target and that seems fixed.
8.2.5.6 beta 1 is available if you want to test it out, let me know if you do.

Please Log in or Create an account to join the conversation.

3 weeks 3 days ago
Maydanoz
Junior Member
Junior Member
Posts: 6
More
Topic Author
Debuff Problems #2231
Thank you for looking into it! I'll try to do some testing early tomorrow.

Please Log in or Create an account to join the conversation.

3 weeks 2 days ago 3 weeks 2 days ago by Maydanoz.
Maydanoz
Junior Member
Junior Member
Posts: 6
More
Topic Author
Debuff Problems #2235
Alright, testing results.

#1 seems partially fixed. Deleting the custom debuff worked, but disabling did not. Not sure if my character's location matters when changing these settings, but I disabled it inside the raid and it was saying "Outside: Bioluminescence (301968) Disabled" while still showing it on my raid frame.

#2 doesn't seem fixed. I still wasn't able to see the Tainted (or Taint) debuff on my Focus frame, even after deleting/readding and disabling/reenabling. I noticed Weakened Soul did show, though.

Please Log in or Create an account to join the conversation.

3 weeks 1 day ago
Strife
Administrator
Administrator
Posts: 706
Karma: 8
More
Debuff Problems #2237
Thanks for testing, I have had time to better look at this.
In beta 2, the enable and disable will work immediately, the bar colour change was again done to elements of a shared debuff cache. The icon still showing regardless was a separate issue but also related to the aura cache, that is also fixed in beta 2.

Will post beta 2 in the next few minutes.

Please Log in or Create an account to join the conversation.

Moderators: ctshammyAcirac