× Bug reports for the Retail version of Healbot

Mouse buttons problem

3 months 1 day ago 3 months 6 hours ago by Strife.
Strife's Avatar
Strife
Administrator
Administrator
Posts: 1373
Karma: 8
More
Mouse buttons problem #19

billi wrote: @strife
not sure why my post is in that thread now but I try to answer as good as possible (which si a bit hard bc I have no idea with whom u are talking now)
my problem only happens so far when my spec automatically switches from Balance to Resto bc of the teleport into the dungeon using dungeon finder


2 thread were merged as it might be the same issue, in your case it is likely due to unregistered everts during zone out/in.
Download the beta at the top of this forum and try that.

Please Log in or Create an account to join the conversation.

3 months 6 hours ago
Strife's Avatar
Strife
Administrator
Administrator
Posts: 1373
Karma: 8
More
Mouse buttons problem #20
@billi Can you confirm if beta 2 fixes this for you?

Please Log in or Create an account to join the conversation.

3 months 4 hours ago
billi's Avatar
billi
New Member
New Member
Posts: 3
More
Mouse buttons problem #21
sadly I cant bc I reached level 60 and bc I havent joined a pact yet I no longer am allowed to us the groupfinder

Please Log in or Create an account to join the conversation.

2 months 3 weeks ago
andrikats's Avatar
andrikats
New Member
New Member
Posts: 3
More
Topic Author
Mouse buttons problem #22
I think it works properly for now, I will post again If I see anything wrong.
The following user(s) said Thank You Strife

Please Log in or Create an account to join the conversation.

2 months 3 weeks ago
sixx's Avatar
sixx
Junior Member
Junior Member
Posts: 7
More
Mouse buttons problem #23
I have the same issue since v9.0.1.0. It may be related to switching specs when the original spec doesn't have anything bound to mouse 4/5. It doesn't appear to have anything to do with the class or spells, I'm able to reproduce the issue on druid/monk/pally. The "fix" I've been using is I open HB spells and click the dropdown for Mouse 4 and then Mouse 5. I don't need to set any of the binds again, just opening Spells > Button > Button4, and then repeating for Button5 makes the mouse buttons work again.

To give a few examples:
-Load into game as mistweaver with mb4/5 bound to spells. Everything works perfect
-Load into game as brewmaster with no binds for mb4/5. When switching specs to MW mb4/5 don't work until I open the healbot spells for mb4/5.
-Load into game as brewmaster with binds for mb4/5. BM binds work and when switching to MW they work as well.

My best guess of what's happening is:
-something is suppose to happen on load, but is ignored when no keys are set for the mouse button.
-When switching specs that code is suppose to run again to check if the other spec needs those buttons, but currently isn't
-This is why opening the HB menu restores the mb4/5 functionality.
-Note reloading after switching specs will also restore the button functionality, likely because it's the equivalent of running the code when loading into the game, except it sees the buttons are bound for mb/4/5 so it works.

Hope this helps with troubleshooting
Thanks
The following user(s) said Thank You throwaway21

Please Log in or Create an account to join the conversation.

2 months 3 weeks ago
throwaway21's Avatar
throwaway21
New Member
New Member
Posts: 2
More
Mouse buttons problem #24
Can confirm what "sixx" wrote. I've been having the exact same issue since Shadowlands launch.

Please Log in or Create an account to join the conversation.

Moderators: ctshammyAcirac